INDUSTRIAL POLLUTION MONITORING SYSTEM USING NODEMCU AND MIT APP INVENTOR

Mr. Kiran.A.R1, Mr. Vikas Kumar 2, Mr. Mahesh R Mesta 3

1Mr. Kiran A.R, Dept. of ECE, Yenepoya Institute of Technology, Moodbidri, India-574225
2Students, Dept. of ECE, Yenepoya Institute of Technology, Moodbidri, India-574225

Abstract - The aim of this project is to develop an application using MIT app inventor which can monitor pollution rate in air in real time and the quality of air and water which can be displayed in the android application.

An application for the Air and Water Pollution Monitoring to display the value of the pollution level in Air in ppm (parts per million) and Water in pH level. Harmful substances including particulates and biological molecules existing in Earth’s atmosphere are main cause of air pollution. These substances results in diseases, allergies or death in humans and also harm to other living organisms such as animals and food crops, and may spoil the natural environment.

Key Words: Internet of things (IoT), Wireless Sensor Network, Massachusetts Institute of Technology.

1. INTRODUCTION

1.1 Objective

Air and water pollution has become a common phenomenon everywhere. Mainly in the municipal areas, air pollution is a major cause of health problems. One of the reason of air pollution is the presence of industrial areas at the outskirts of the major cities is the main causes of air pollution. In metropolitan cities people are seriously intensified due to air pollution. Through the world wide all Governments are seriously taking this is main challenge to reduce or avoid air pollution. The aim of this project is to develop an application using MIT app inventor which can monitor pollution rate in air in real time and the quality of air and water which can be displayed in the android application.

2. PROPOSED ARCHITECTURE

2.1 Power Supply

A power supply is an electrical device that supplies electric power to an electrical load. The primary function of a power supply is to convert electric current from a source to the correct voltage, current, and frequency to power the load. As a result, power supplies are sometimes referred to as electric power converters. Some power supplies are separate standalone pieces of equipment, while others are built into the load appliances that they power. Examples of the latter include power supplies found in desktop computers and consumer electronics devices. All power supplies have a power input connection, which receives energy in the form of electric current from a source, and one or more power output connections that deliver current to the load.

2.2 NodeMCU ESP8266

The NodeMCU project incorporates firmware with a prototyping board. The name "NodeMCU" combines "node" and "MCU". The term "NodeMCU" strictly speaking refers to the firmware and prototyping (development) board rather than the associated software development kits. Both the firmware and prototyping board design are open source.
The firmware uses the Lua scripting language. The firmware is based on the eLua project, and built on the Espressif Non-OS SDK for ESP8266. It uses many open source projects, such as Lua-cjson and SPIFFS. Due to resource constraints, users need to select the modules relevant for their project and build a firmware tailored to their needs. Support for the 32-bit ESP32 has also been implemented.

2.3 16 bit I2C ADC (ADS1115)

The ADS1115 are precision Analog-to-digital converters (ADCs) with 16 bits of resolution offered in an ultra-small, leadless package. The ADS1115 feature an on board reference and oscillator Data are transferred via an I2C-compatible serial interface four I2C slave addresses can be selected. The ADS1115 operate from a single power supply ranging from 2.0V to 5.5V. The ADS1115 can perform conversions at rates up to 860 samples per second. An on board PGA is available on the ADS1114 and ADS1115 that offers input ranges from the supply to as low as ±256mV, allowing both large and small signals to be measured with high resolution. The ADS1115 also features an input multiplexer that provides two differential or four single-ended inputs.

2.4 Air Quality Sensor (MQ-135)

The MQ-135 Gas sensors are used in air quality control equipment's and are suitable for detecting or measuring of Benzene, Smoke, and CO2. The MQ-135 sensor module comes with a Digital Pin which makes this sensor to operate even without a microcontroller and that comes in handy when you are only trying to detect one particular gas. The air quality sensor has a small potentiometer that permits the adjustment of the load resistance of the sensor circuit. The 5V power supply is used for air quality sensor.

2.5 Carbon Monoxide Sensor (MQ-9)

The carbon monoxide Sensor (MQ9) module is useful for gas leakage detection in industries. It is suitable for detecting CO, CH4. Due to its high sensitivity and fast response time, measurements can be taken as soon as possible. The sensitivity of the sensor can be adjusted by using the potentiometer. Sensitive material of MQ-9 gas sensor is SnO2, which with lower conductivity in clean air. It make detection by method of cycle high and low temperature, and detect CO when low temperature (heated by 1.5V). The sensor’s conductivity is higher along with the gas concentration rising. When high temperature (heated by 5.0V), it detects Methane, Propane etc. combustible gas and cleans the other gases adsorbed under low temperature. Please use simple electro circuit, Convert change of conductivity to correspond output signal of gas concentration. MQ-9 gas sensor

2.6 pH Sensor (PH 0-14)

pH probes measure pH by measuring the voltage or potential difference of the solution in which it is dipped. Hence, a pH probe measures the potential difference generated by the solution by measuring the difference in hydrogen ion concentration using the Nernst equation and displays the pH as output. pH is an important parameter to be measured and controlled. The pH of a solution indicates how acidic or basic (alkaline) it is. pH sensor components are usually combined into one device called a combination pH electrode. The measuring electrode is frequently glass and quite fragile. Recent developments have replaced the glass with more durable solid state sensors.

3. IMPLEMENTATION AND WORKING

3.1 Installing the Arduino IDE

First you must have your Arduino and a USB cable. In case you use Arduino UNO, Arduino Nano, Arduino Mega 2560, or Diecimila, you will need a standard USB cable (A plug to B plug), the kind you would connect to a USB printer.

3.1.1 Launch Arduino IDE

You can get different versions of Arduino IDE from the Download page on the Arduino Official website. You must select your software, which is compatible with your operating system (Windows, IOS, or Linux). After your file download is complete, unzip the file.

After your Arduino IDE software is downloaded, you need to unzip the folder. Inside the folder, you can find the application icon with an infinity label Double-click the icon to start the IDE.

3.1.2: Installing The ESP8266 board to Arduino IDE

To install the ESP8266 board in your Arduino IDE, go to File> Preferences and Enter http://arduino.esp8266.com/stable/package_esp8266co m_index.json into the “Additional Boards Manager URLs” field. Then, click the “OK” button. Open the Boards Manager. Go to Tools > Board > Boards Manager Then Search for ESP8266 and press install button for the “ESP8266 by ESP8266 Community” and ESP8266 Board is installed on Arduino IDE.

3.1.3: Installing Library Files to Arduino IDE

To install a new library into your Arduino IDE you can use the Library Manager. Open the IDE and click to the “Sketch” menu and then Include Library > Manage Libraries. Then Search for Arduino Firebase and install library than Search for ArduinoPjxson and install it. Then install library file for ADS115 module.
3.2 Creating Project on Firebase

Open the Firebase console on chrome and Click on "CREATE NEW PROJECT". Then enter the project name and choose country. After this go to the Database and click on realtime database and get the authentication URL. Then copy it to the program. Next goto the project setting > service accounts >Database secrets after this copy the "token Secret" and passed it on arduino program.

3.3 Creating Application using MIT App Inventor

To create an app go to the MIT app inventor official website login with email account then click on new project and give name for project. Drag and dropped the components for creating layout in designer window and in block window arrange the code block in logical manner for proper operation of android app. Go directly to ai2.appinventor.mit.edu click on "Create" button from the App Inventor website. Use an existing Gmail account to log in to ai2.appinventor.mit.edu.

Create new project and give name for application. In MIT App inventor there are two windows one is design window and another is blocks editor.

The Design Window is where we can create layout for an app, and we have to specify the functionalities required for layout. We can choose components for the user interface things like Buttons, Images, and Text boxes, and functionalities like Text-to-Speech, Sensors, and GPS.

The Blocks Editor is where we can program the behavior of app. There are built-in blocks that handle things like math, logic, and text. Below that are the blocks that go with each of the components in our app. In order to get the blocks for a certain component to show up in the Blocks Editor, we first have to add that component to your app through the Designer.

3.4 PPM calculation for MQ-2 sensor

The graph tells us the concentration of a gas in part per million (ppm) according to the resistance ratio of the sensor (RS/R0). Hence in this project MQ-2 sensor is used for detection of CO (Carbon monoxide).

1) RS is the resistance of the sensor that changes depending on the concentration of gas.

2) R0 is the resistance of the sensor at a known concentration without the presence of other gases, or in the fresh air.

RS = [(Vin x RL) / Vout] - RL

Where:

Vin is 5V
RL is 10 k Ohm
Vout is the analog voltage reading from the sensor

The resistance ratio in fresh air is a constant, where R0 is the resistance of the sensor at fresh air.

RS / R0 = 9.8

The scale of the graph is log-log. This means that in a linear scale, the behavior of the gas concentration with respect to the resistance ratio is exponential. The data for
gas concentration only ranges from 200 ppm to 10000 ppm.

Equation for straight line:
\[ y = mx + b \]

Where:
- \( y \): Y value
- \( x \): X value
- \( m \): Slope of the line
- \( b \): Y intercept

Where the graph for ppm conversion is in log-log:
\[ \log (y) = m \log (x) + b \]

Applying the logarithmic quotient rule:
\[ m = \frac{\log (y/y_0)}{\log (x/x_0)} \]

Now we substitute the values \( x=10000 \), \( x_0=200 \), \( y=5.1 \), and \( y_0=1.4 \) for carbon monoxide gas:
\[ m = \frac{\log (5.1/1.35)}{\log (10000/200)} \]
\[ m = -0.339 \]

Now that we have \( m \), we can calculate the \( y \)-intercept. To do so, we need to choose one point from the graph
\[ \log (y) = m \log (x) + b \]
\[ b = \log (y) - m \log (x) \]
\[ b = \log (1.8) - (-0.339) \log (5000) \]
\[ b = 1.512 \]

We have \( m \) and \( b \), we can find the gas concentration for any ratio with the following formula:
\[ \log (x) = \frac{\log (y) - b}{m} \]
\[ x = 10^{\left\{ \frac{\log (y) - b}{m} \right\}} \]

Fig 3.4.2: M and B values for different gases

3.5 PPM calculation for MQ-135 sensor

To calculate the CO2 level in ppm, first we need to calculate the slope for CO2 gas from graph, and the slope is \( m=(y_2-y_1)/(x_2-x_1) \) but we are in log scale then the formula with logarithmic laws comes from \( m = \log (y_2 \cdot \log y_1) / (\log x_2 - \log x_1) \)

1) \( R_s \) is the resistance of the sensor that changes depending on the concentration of gas.

2) \( R_o \) is the resistance of the sensor at a known concentration without the presence of other gases, or in the fresh air

From the graph we can get the co-ordinates \( y_2, y_1, x_1, x_2 \) for CO2 gas

\( \text{CO2 (10, 2.3), (200, 0.8)} \)

Where:
\[ x_1 = 10 \]
x2 = 200

y1 = 2.3

y2 = 0.8

\[ m = \frac{\log (0.8/2.3)}{\log (200/10)} = -0.3525 \]

The function is \[ y = \left[2.3/10^{(-0.3525)}\right] * x^{(-0.3525)} \]

\[ x = 96.9691 * y^{(-2.83688)} \]

Where \( y = (Rs/Ro) \)

PPM = 96.9691 * (Rs/Ro)^(-2.83688)

Equation depends on measured slope.

4. RESULT AND CONCLUSION

Fig 4: Snapshot of Android App

It will help the people who are living nearby industrial area to know about pollution rate and they can complaint to pollution control board. In this project android application will display the amount of pollution released by the industries.

This system can be installed at polluted areas, It will be helpful for the people who are having breathing problems.

REFERENCES

[1]. Harsh N. Shah and Zishan Khan, “IOT Based Air Pollution Monitoring System”, Assistant Prof


